Happy Meeple forum

General => Tips, polls, updates => Topic started by: Crystal V. on 15/06/16, 03:19am

Title: Can't get to menu page
Post by: Crystal V. on 15/06/16, 03:19am
Hi folks,

starting a few days ago, after I login (with facebook credentials) I am directed to the menu page and I can see the buildings, but nothing else happens. I have tried this in both Internet Explorer 11 and Google Chrome, both behave the same. Reboots of my computer and wireless router make no change.

Any help would be appreciated, I can't play any games right now!

Title: Re: Can't get to menu page
Post by: Jimmy V. on 15/06/16, 10:39am

Thanks for letting us know!

Can you send me your password via the contact form? Or if you don't want to, change it before (you can do this on the login page).

Then I can access your account and find out what is going on. Right now, there is no Javascript error coming from your login. So I have no clue what is going on.

Title: Re: Can't get to menu page
Post by: Crystal V. on 21/06/16, 05:54pm
Hi Nicolas,

I don't think I need to give you my password, I can't even play as a guest. We've tried on two different computers and get the exact same result (logged in or guest). We have also tried from one of our Android smartphones on the cellular network (as opposed to on our home wifi and internet connection). Same result.

I've attached a screenshot of trying to play as guest, I just get a blank map. When logged in, I see my buildings but that is all that happens.

Title: Re: Can't get to menu page
Post by: Jimmy V. on 21/06/16, 06:13pm

I don't find any Javascript error in my logs.

If the issue is not account-specific nor computer specific, it is really weird. The only explanation I can think of is the Internet provider blocking something. Maybe you can look on that side. Any software that could block things? Any blocking from the ISP?

What browsers did you try on?

Let me know!
Title: Re: Can't get to menu page
Post by: Crystal V. on 22/06/16, 04:40am
Ok, so my testing with the Android device earlier was rushed. I must not have opened a new browser after turning off the wifi or something. Anyway, will fresh testing tonight, I can successfully load the menu page from my Android phone while connected to the cellular network.

I further tested this by creating a wifi hotspot, connecting my laptop, and the menu page loads just fine.

Now comes the fun part... I haven't yet determined if the problem is with my ISP and the modem, or my wireless router.

I can, however, say the problem is related to WebSockets. Using Telerik Fiddler, I've captured the traffic while on my home wifi and while connected to my cellular hotspot.

All requests are more or less identical until it makes the following request:

GET http://4.ape2.happymeeple.com/6/

This appears to be where it initiates the WebSockets connection. In the screenshot, on the left you can see the connection on wifi. It initiates a connection, then never receives any other response. On the right, connected to my cell phone, there are a number of WebSockets messages exchanged. As already mentioned, the menu page loads just fine when connected to the internet via hotspot from my phone.

So, I'd say the problem is still on my end, now to just figure out if the router is the problem or something upstream with my ISP.

I should add that this is Crystal's husband Tom doing the troubleshooting and  testing, she just want's to play her game again :)

Title: Re: Can't get to menu page
Post by: Crystal V. on 22/06/16, 04:55am
That took less time than I thought to confirm... I had another router down in the basement and made the swap. I can now launch the menu just fine, no WebSockets issues show up in Fiddler.

My problem isn't fully solved though, because this other router I had kicking around I had previously removed from service because it wasn't stable... So, I guess I'll be going shopping for a new router and BOTH of these can be taken out of service!

Just in case you see this come up again, the problem router is a D-LINK DIR-615 running the latest firmware. No idea why it is having problems with WebSockets traffic!!

Title: Re: Can't get to menu page
Post by: Jimmy V. on 22/06/16, 11:09am
Glad you found an explanation.

Thanks for posting your findings!

Very interesting.