Author Topic: Lost Cities Scoring question  (Read 9400 times)

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Lost Cities Scoring question
« on: 16/05/17, 08:48am »
I've been unable to figure out the "Expedition scoring" page subtotals more than a few times and assumed it was me, given the many (many) experienced players here. But now I've given up, I just don't understand the logic.

Please advise! and thank you.

Happy Meeple

  • Administrator
  • Hero Member
  • *****
  • Posts: 768
  • Karma: 129
Re: Lost Cities Scoring question
« Reply #1 on: 16/05/17, 09:09am »
Well, indeed, that's weird!!!

The 148 should be 108 (4X27). Then the bonus of 20 is added to get to the correct final score 128.

Well spotted. I wonder why noone ever complained about it. Maybe it only occurs in certain instances.

Anyone else has seen this?

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Re: Lost Cities Scoring question
« Reply #2 on: 16/05/17, 11:12am »
Thank you, I'm glad to know it's not me! Here's another just played, it's the green cards. They both might be the green cards.


Happy Meeple

  • Administrator
  • Hero Member
  • *****
  • Posts: 768
  • Karma: 129
Re: Lost Cities Scoring question
« Reply #3 on: 16/05/17, 05:39pm »
Again, it added 40 points unnecessarily.

What is your browser?

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Re: Lost Cities Scoring question
« Reply #4 on: 17/05/17, 06:33am »
Most often I play on a Firefox 45.0.2 eme-free.

Sometimes I play on another browser or another computer and I will try to check there for the error. I can tell you also, after posting that last screenshot I continued playing LC and didn't see the error again. And that is consistent with prev experience, where only occasionally I would check and only a percentage of those checks would note an odd subtotal.

Lost Cities was new to me so it took a while for me to become comfortable with the scoring and puzzled enough to look further when I happened upon it again.   

UPDT:
If it's the type of issue that you think may just be down to old tech, then I have to be even more judicious about the items brought to your attention. Most sites I use including game playing don't seem affected however your site is newer plus you have probably more advanced AI. My experience is that most things work fine for me and when something doesn't it's fairly obvious as to why. But if the tech here may result in more nuanced issues... well, all I can say is that my intent isn't to cause you unnecessary work or pointless investigation on old tech vs new tech issues and if that is what's happened I'm sorry.
« Last Edit: 17/05/17, 06:50am by Jamie A. »

Happy Meeple

  • Administrator
  • Hero Member
  • *****
  • Posts: 768
  • Karma: 129
Re: Lost Cities Scoring question
« Reply #5 on: 17/05/17, 11:15am »
Don't worry! It is most likely not related to your browser. And your help is most appreciated.

It seems to happen only when there is an 8-card bonus anyway. So it is most likely where the issue resides. I'll have to check my code.

In the meantime, if others have an 8-card bonus, I'd like them to check if the computation is right or wrong.

Have fun!

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Re: Lost Cities Scoring question
« Reply #6 on: 17/05/17, 02:27pm »
You're quite kind, thank you. Also probably correct about the bonus. I just saw another one that was on the bonus ( 17 x 3 = 91 ) and oddly again also on the green cards.

UPDT: ah, finally got one not on green cards ( 17 x 2 = 74 ) 
« Last Edit: 18/05/17, 02:25am by Jamie A. »

Happy Meeple

  • Administrator
  • Hero Member
  • *****
  • Posts: 768
  • Karma: 129
Re: Lost Cities Scoring question
« Reply #7 on: 14/06/17, 12:30pm »
I have uploaded the fix to correct the issue. Let me know if it still does not work.