Author Topic: Connection Issue msgs so far only on Lost Cities  (Read 9011 times)

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Wondering if there is a reason I get so many Connection Issue messages on Lost Cities, and only on Lost Cities... Will take troubleshooting suggestions if there is anything I should be checking.

Thanks.

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Re: Connection Issue msgs so far only on Lost Cities
« Reply #1 on: 16/04/17, 01:08pm »
Also it occurs to me... I played as a guest quite a few various games before creating an account. Lost Cities issues existed across 3 browsers and 2 computers and I found/find it unpredictable as to whether it will work just fine or be slow from the start or slow down as I play, even in Training mode. When it occurs I don't seem to be able to 'fix it' with standard things like rebooting, clearing cache, closing other programs, etc. I just have to wait and try again later.

Slowdowns, at least visually, seem to center around the cards flying across the screen.  I don't know how doable this would be programmatically, but if I had the option to turn off the Flying Card animation I would certainly do it. Probably a separate issue from the Connection messages...

Bartholomew .

  • Jr. Member
  • **
  • Posts: 2
  • Karma: 0
Re: Connection Issue msgs so far only on Lost Cities
« Reply #2 on: 16/04/17, 08:27pm »
I have run into this issue as well. I can't say for sure, but I imagine maybe it has to do with the number of users playing games on the server at a given time. The moderators would have a better understanding of this than me, but that is my hunch.

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Re: Connection Issue msgs so far only on Lost Cities
« Reply #3 on: 20/04/17, 02:41pm »
I noticed tonight received the msgs also on LevelX...

Jimmy V.

  • Administrator
  • Hero Member
  • *****
  • Posts: 772
  • Karma: 133
Re: Connection Issue msgs so far only on Lost Cities
« Reply #4 on: 21/04/17, 12:36am »
Hi,

Connection issues and slow animations are totally different things. The first one depends on the quality of the Internet between you and our server. The second one depends on your browser and machine.

Regarding connection issues, we don't have bigger rates on specific games. It appears that we display "Connection issue" messages a bit too quickly. We will see if we can make those appear less often. At the moment only a few seconds of lag will trigger the message.

Regarding your browser/machine, it is always helpful to close all your browser windows and restart afresh. Rebooting the machine can also be a good thing sometimes. In any case, if you hear your hard drive for long periods, it is time to do something, a program may be taking most of your resources and it may affect your browser and your game.

Nicolas.

PS: we believe that our server is much bigger than we need at the moment. We can absorb much more traffic. So don't hesitate to invite friends, directly or via a table URL (all you need is to share the link to your table and your friends will create an account and join you in a few seconds).


Ernest F.

  • Newbie
  • *
  • Posts: 1
  • Karma: 1
Re: Connection Issue msgs so far only on Lost Cities
« Reply #5 on: 21/04/17, 04:15am »
Hi,

My internet is slow, I can't deny it. But the thing is once you are reconnected you can't play anymore, the game is frozen. So you loose the game everytime. At least that is how it is for me. I also feel sending messages to the person you play with doesn't help.

I agree with the idea of disabling flying cards and also the flying circle that goes in the middle (where you put cards that the other player can take).

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Re: Connection Issue msgs so far only on Lost Cities
« Reply #6 on: 21/04/17, 05:36am »
Connection issues and slow animations are totally different things. The first one depends on the quality of the Internet between you and our server. The second one depends on your browser and machine.
From the user perspective animations are related because while the Connection messages are dropping (over and over), I'm waiting for the card to fly across the screen. So my point there might have been muddied. I have had some instances where the animation itself has become jerky during the flying, but that's not as frequent. However it does mean that if I could stop the animation I would because it would decrease the overall level of disruption experienced during game play.

Regarding quality of the internet, all I can say is that I don't have any problem watching streaming video online. I would think your games aren't heavier than that but it's a guess based on no data. Maybe they are heavier.

Lost Cities definitely is more problematic for me than LevelX though. With LevelX I received a few messages, whereas with Lost Cities some games it's three quarters of the card selections and I resize my browser after many of my clicks to keep the game moving along. I don't know if that really helps, but visually it seems to.

Jimmy V.

  • Administrator
  • Hero Member
  • *****
  • Posts: 772
  • Karma: 133
Re: Connection Issue msgs so far only on Lost Cities
« Reply #7 on: 21/04/17, 03:36pm »
At what time do you usually play Jamie?

Most of what you are seeing is delays between the moment you send your move to the server (drawing a card from the deck I suppose) and the moment the animation starts (meaning you have received the information about the new card from the server).

I don't think it has anything to do with your machine but more with Internet lags. I know quite a few people complain about this too. We still don't know whether there is something we can do about it or not. Personally, I have hardly ever seen any slow down or disconnection during a game. But I live in London and the server is also hosted somewhere around London.

Jamie A.

  • Hero Member
  • *****
  • Posts: 89
  • Karma: 14
Re: Connection Issue msgs so far only on Lost Cities
« Reply #8 on: 22/04/17, 06:01am »
Re: What time? Right now I'm playing at all different times because my schedule allows and I'm playing a lot because it's shiny and new to me.  :) 

I'm in the USA.

There have definitely been some instances where the game is mostly smooth, and (more often) other times where I get Connection msgs as I said on 3/4 of clicks. At this point I'm presuming it's time related as it doesn't seem to matter what I do here to my computer to try resolving. Lost Cities is definitely the biggest offender though so far. It can be barely functional and I'll change to LevelX and that one will work fine.

UPDT: Okay I just played back to back, first LevelX and received no Connection msgs.

Then I played Lost Cities and received Connection msgs on every draw pile click except 2. And the msg display showed either 1 msg quickly followed by a group of 6 msgs, or a group of 7 msgs together. Maybe once or twice only a group of 6 but mostly a total of 7.

Playing next game of Lost Cities now I'm getting 8 and 10 messages on each draw up until the last few with no msgs. But the animations are fine, no jerkiness.

Now 2 more games of LevelX, no msgs.
« Last Edit: 22/04/17, 07:00am by Jamie A. »