Happy Meeple forum

Our games => Lost Cities => Topic started by: Shannon H. on 22/03/18, 11:57pm

Title: Bug: tiles showing clear
Post by: Shannon H. on 22/03/18, 11:57pm
Instead of green tiles, they were clear. They were fine once played.
Only happened to me, not my opponent. The previous game with the same opponent, no issue.
Next game, no issues
Title: Re: Bug: tiles showing clear
Post by: Stephanie E. on 23/03/18, 07:24pm
I am having the same bug.. 2 of 3 games with clear cards.  First time it was only the blue.. this game was yellow, blue and white! 
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 24/03/18, 10:36am
It looks like it is a widespread issue. I suspect this is related to a particular browser that has just been upgraded automatically to a new buggy version.

Please all tell me what browser you are playing with!
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 24/03/18, 11:35am
FYI, all 4 users that reported the issue were using Chrome version 65.

For the moment, I can only recommend using another browser like Firefox.

I have not seen any related bug report on Chrome pages. I'll keep you posted.

Thanks!
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 24/03/18, 11:43am
If you get the issue, please post a screenshot here (or to our usual address contact at happy...ple.com).

This will help us narrow down the issue! I have just updated my browser, but have not been able to reproduce the bug yet.

Thanks!
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 26/03/18, 05:55pm
Stephanie E. has confirmed that pressing the Ctrl-F5 key combination solved the issue (at least temporarily).

So if you are playing an online game, just press Ctrl-F5. The page will reload, with a cache refresh, which means the browser will get all elements of the page again. So the missing one should come back.

F5 refreshes the page but does not clear the cache.

PS: our new feature (of the day) lets you refresh a game that is stuck. That's why I am recommending Ctrl-F5 on online games. If you use it on a training match, you will not be able to complete it. A new game will start instead (if you have enough food).

PS2: the bug has been reported to Google. See the bug report (https://bugs.chromium.org/p/chromium/issues/detail?id=825634&can=2&start=0&num=100&q=&colspec=ID%20Pri%20M%20Stars%20ReleaseBlock%20Component%20Status%20Owner%20Summary%20OS%20Modified&groupby=&sort=).




Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 15/04/18, 09:02am
Hello all,

For those who do have the bugs, can you let me know the answer to this question? We need this information to help Google find the issue.

1) when the cards are transparent, does this always happen the first time a particular color is shown or is it possible that sometimes, the card (for example green) displays correctly and at some point turns transparent?

2) do you have a good Internet connection?

Thanks for your help!



Title: Re: Bug: tiles showing clear
Post by: Jeff M. on 15/04/18, 05:36pm
The Crtl+f5 doesn't work for me on a Mac with Chrome 65.0.3325.181  installed.

The transparent cards only happened twice to me.  All the cards on the screen were transparent.

I have a very fast and usually stable internet connection.
Title: Re: Bug: tiles showing clear
Post by: Guest 171790 on 17/04/18, 04:16pm
Hello all,

For those who do have the bugs, can you let me know the answer to this question? We need this information to help Google find the issue.

1) when the cards are transparent, does this always happen the first time a particular color is shown or is it possible that sometimes, the card (for example green) displays correctly and at some point turns transparent?

2) do you have a good Internet connection?

Thanks for your help!

1) The game starts with a color showing transparent and it does not change until the end of the game.
2) I have a decent internet connection
Title: Re: Bug: tiles showing clear
Post by: Brad L. on 19/04/18, 07:45am
I just hit the issue in both Lost Cities and Siberia tonight.  I am using Chrome 65.0.3325.181.

In Lost Cities both blue and green cards in my hand were clear, others showed fine.  Green and blue cards played on the discard piles were also clear but those played on the path showed correctly.  This was consistent the whole game.

In Siberia all cards in my hand were fine.  Diamond cards for purchase were clear but all others showed fine.  Again it was consistent, every diamond card was clear for the whole game.
Title: Re: Bug: tiles showing clear
Post by: Brad L. on 19/04/18, 08:09am
I played two more games of Lost Cities.  The first one the blue cards were fine but the green cards were clear.  The rest of the cards continued to show up correctly.  The next game all cards showed up fine.  I did press Control F5, Shift F5, and F5 several times before I played these two games but not between them so that wasn't what corrected green in the last game.
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 19/04/18, 11:13am
Thanks Brad,

It helps to know that the cards are always transparent during the game from start to finish.

Regarding Ctrl-F5 (if you are on Windows), can you let me know if it fixes the issue (do it only for online games that can reload, training games can't).
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 23/04/18, 10:12am
Hello there,

We need more feedback.

When the bug happens, please report it here with the following information:

- match id, the match id is in the URL. Look at the address bar
- machine: desktop, tablet, mobile
- browser
- internet connection quality: bad, good, very good
- internet connection type: cable, wifi, mobile data (Edge/3G/4G)

Thanks for your input! This will let us look at our logs at the exact time the problem occurred and see if we can find a hint.


Title: Re: Bug: tiles showing clear
Post by: Guest 198964 on 25/04/18, 03:58pm
Just received the same glitch while playing a tutorial. The blue deck was the only cards effected by the glitch.

The match ID = 2736469
System = Windows PC
Chrome Browser
Good Network connectivity
Wifi network connection
Title: Re: Bug: tiles showing clear
Post by: Guest 171790 on 27/04/18, 03:59pm
Every single tile was transparent on my game :/
match id 2740672
windows 10 laptop
chrome
connection ok, wifi (home)
Title: Re: Bug: tiles showing clear
Post by: Jeff M. on 27/04/18, 08:02pm
Windows 10. Desktop.
Chrome Version 65.0.3325.181

Wired connection.
Stable connection.
http://www.happymeeple.com/en/game.php?match_id=2741185

Only grey cards were clear.  Crtl f5 fixed it.

Then during the match when my first green card showed in my hand it was clear.  Ctrl f5 fixed it again.
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 01/05/18, 06:21pm
Hi guys,

Since we can't reproduce the issue on our end, we really need your help here. We need someone to delve into this for us.

If any of you is a little technical (ideally a web developer, but it is not absolutely necessary), can you do this when the bug happens?

1) Right-click on the transparent card, then choose the "Inspect" option (should be at the bottom of the menu).
This will open the developer debugging tools.

2) See attachment #1.
The tool will be opened in the Elements tab and the card element of the page will be selected. Check out there if you can see anything special. But most importantly, right click on the right of the page on the URL of the image. A sub-menu will appear, choose "Open in new tab". This will open the image in a new page. You should tell me if the page is empty or if the image shows up. Let me know also if the image did not suddenly appear in the original page (normally not but you never know)

3) See attachment #2.
Go back to the original page and click on the "Console" tab. Scroll up and down the content of the console (lots of text). If you see anything red, please let me know!

4) See attachment #2 and #3.
Click on the "Source" tab and look for the image in the /img/LC/ folder (if for Lost Cities, otherwise look for the appropriate 2 letters folder name for the game, for example HK for Hanamikoji) and find the appropriate missing image in the list of images. In the attachment, you can see a green card appearing. Let me know if the missing image is there or not and if it is there, if it shows up in the debugging tool.

5) See attachment #4 and #5
Now leave the debugging tool open (if you are playing online only), and click on F5 (not Ctrl-F5!!!).
This should refresh the page. But now the "Network" tab should be populated and give information.
Click on the "Network" tab. The select "Img" to filter the images. Now find the transparent image in the list (for example card_bg_blue_44_50.png for a missing blue card in Lost Cities). Take a screenshot when you have found it!
Now click on the image, more information should be displayed. Take a screenshot of the header information, then click on Preview, Response and Timing and do the same.

I am quite confident that all these steps will help us find out what is going on. So far, Google has not been able to find out what the problem is. And we know it comes from them as the bug does not happen in Firefox.

A big thank you to the person who will help us on this. The bug seems to happen quite frequently. So I am confident someone will do this procedure soon enough.

Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 01/05/18, 06:23pm
Attachment 5.
Title: Re: Bug: tiles showing clear
Post by: Happy Meeple on 10/05/18, 11:22am
Still looking for more information. Read above.
Title: Re: Bug: tiles showing clear
Post by: Sainivedant S. on 19/01/21, 04:43pm
I just hit the issue in both Lost Cities and Siberia tonight.  I am using Chrome 65.0.3325.181. mobdro (https://get-mobdro.com/home/)

Regards, authorityapk (https://authorityapk.com)