General > Tutorial, training, online play

Bug in "access limited : play with friends option" ?



I'd like to report what seems to be a bug. That or I am really missing something.

I just started a game of Lost Cities and wanted to play against a bot, so I chose "access to the table is limited" and then "only friends" (of which I have none). And sure enough, within barely a second, I was playing against another user. How does that happen ?

It is not the first time I notice this. So far I have observed it only with Lost Cities but I do not know whether this bug is present for all games, or just Lost Cities.

My assumption is that the players I am matched with chose the simplified interface (from home/games and not the inn). I assume that a human player in the inn wouldn't join a table as quickly and casually if there is a lock icon on top of it, but a human having chosen "play" via the simplified interface would just let the program find a match and would not know how the opponent was found. This program could "forget" to check the accessibility options of the currently open tables waiting for a game to begin, and thus send the player on a supposedly limited access table.

I didn't ask the player I just played with (on the other hand, he didn't even reply to "hi !"). Next time I could try to investigate with my undesired opponent how he or she ended up matched with me. Though I'd rather just not have the problem at all.

Since I'm reporting about this issue, I'd like to ask : what is the use of the option "access to the table is limited", sub-option "all players" ?
I understand "friends", "selection of friends" and "link only", but "all players" sounds contradictory with "limited access", and redundant with "the table is open to everyone". Also, from a code perspective, I can see how this would open the door to bugs. If there is no good reason for it (perhaps there are some that I just can't think of), perhaps it would be preferable to remove it. It could even remove the bug I reported.

Guest 171790:
Hello Regisbull!
Have you tried "access by link only"?
I m not saying this is the answer to your post. This way just works for me when I want to play against a bot. :)

Jimmy V.:
Thx for reporting this! I’ll check this soon. It’s holiday time for now.

Yes, I have tried using "access by link only", it works.

But for one thing, it causes a pop-up window/message that gives me the link and which I have to close before starting, so it's slightly inconvenient (very slightly, I admit). Secondly, it is just a "quick and dirty" work-around that does not solve the problem. So I thought it would be more likely to be spotted and repaired if I reported it.

@Happy Meeple : cool ! I think enquiring into and repairing the issue with "restricted > friends only" is the most important. But if you can see about "restricted > all players" as well, that'd be great.


[0] Message Index

Go to full version